libc.so.6(GLIBC_2.14)(64bit) is needed by…问题的解决办法

在使用Linux服务器过程中,是否有遇到过“libc.so.6(GLIBC_2.14)(64bit) is needed by…”的问题,像小编就遇到了类似的问题:

安装rpm -ivh MySQL-client-advanced-5.6.22-1.el7.x86_64.rpm提示

[root@localhost src]# rpm -ivh MySQL-client-advanced-5.6.22-1.el7.x86_64.rpm

  error: Failed dependencies:

  libc.so.6(GLIBC_2.14)(64bit) is needed by MySQL-client-advanced-5.6.22-1.el7.x86_64

出现这种问题的原因是因为系统的glibc版本不符合安装要求,可以对glibc进行升级解决该问题。

Glibc升级步骤:

1、访问http://ftp.gnu.org/gnu/glibc/glibc-2.14.tar.gz下载响应安装包(根据具体问题选择对应的glibc版本);

2、下载后执行以下命令:

tar zxvf glibc-2.14.tar.gz

  cd glibc-2.14

  mkdir glibc-build-2.14

  cd glibc-build-2.14

  ../configure –prefix=/opt/glibc-2.14

  make

  make install

Glibc是向下兼容的,一般根据需要选择高一点的版本(比如同时出现需要2.14和2.17的Glibc版本,升级到2.17即可)。需要注意的是libc.so.6是基础库,操作要谨慎。

以上就是大家在使用Linux服务器的时候遇到“libc.so.6(GLIBC_2.14)(64bit) is needed by…”问题的解决办法,希望能帮助到大家。

性价比高的Linux服务器推荐:Kyrpt美国服务器RAKsmart美国服务器

赞(0)
未经允许不得转载:服务器之家 » libc.so.6(GLIBC_2.14)(64bit) is needed by…问题的解决办法

评论 抢沙发

  • 昵称 (必填)
  • 邮箱 (必填)
  • 网址